All March 1st recurring events have now completed successfully. If you have any ongoing issues, please let us know in chat support.
Posted Mar 01, 2025 - 11:42 MST
Monitoring
We have identified the issue that prevented recurring tasks from running on the morning of March 1st. The system is now working through a small backlog of requests and all invoices and other March 1st events should be executing over the next 20-30 minutes.
Posted Mar 01, 2025 - 11:17 MST
Investigating
We are investigating an issue with March 1st invoices not running on time.
We advise no action on your part at this time. We will update this incident once the issue has been resolved.